Home Forums Themes Support Pricom Unable to change colors. File Permission Issues?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #12337

    I uploaded the Pricom Theme and the Pricom Child Theme and activated it. I installed all required plugins and started to configure the page. Changing the Typography works without a problem and changes are reflected on the website immediately. When I changed the Primary Color and clicked “Save Changes” it says “Settings Saved!” but the changes are not reflected on the website (the button color is still the standard red). I checked on a different device that has never visited the site before and it is also standard red.

    At the top of the Theme Options page I noticed two identical notifications:

    “File Permission Issues
    We were unable to modify required files. Please ensure that /var/www/html/wp-content//uploads/ has the proper read-write permissions, or modify your wp-config.php file to contain your FTP login credentials as outlined here..”

    The permissions are fine and I can upload media without any problem. I don’t know if this error and the colors not being reflected on the website are related but it is the first time I encountered any one of these problems.

    What could be the reason and how can I fix it?


    Thanks for contacting us and choosing our product!
    It seems your folder uploads doesn’t have permission to create new style.custom.min.css file
    Please make sure your wp-uploads folder have permission 755
    If you don’t know how to change it you can contact your hosting provider change it for you!
    And please make sure SCSS Compiler option is Enabled:
    Hope this helps!


    • This reply was modified 1 month, 1 week ago by admin.

    Thank you for the quick and helpful reply.
    Sorry, my fault for not reading the instructions: Setting the SCSS Compiler option to enabled solved the color problem.

    However, the warning is still displayed: The style.custom.min.css exists and both the uploads folder and the style.custom.min.css are set to 775 but the warning won’t go away.

    I’ve only begun to set everything up and so far did not run into any other problems. So for now I will ignore the warning and just continue. If I run into any problems I will check back here.

    Thanks again for the help.

    Edit: Just for more context: I’m running WordPress with docker compose and the data volumes are mounted to the host system.

    • This reply was modified 1 month, 1 week ago by david-w.

    It seems the issue come from Redux Framework plugin when update to the latest version.
    Sorry for the issue with folder, it’s 755 and we updated path in the previous reply.
    The notice message com from: wp-content/plugins/redux-framework/redux-core/assets/inc/classes/class-redux-filesystem.php
    You can remove this on line 445 to hide the error:

    Redux_Admin_Notices::set_notice( $data );

    We’ll contact the plugin author about this. However it seems the issue from server side and you can contact your hosting provider about it too.


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.